僕は発展途上技術者

Mac OS X Mavericks にアップデートしたら bcrypt-ruby gem がインストールできなくなったときの対処法

brypt-ruby に限らずだと思うのだが、Mavericks にアップデートし、bundle install で


Installing bcrypt-ruby (3.1.1)

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.


というエラーがでたときの対処法。

» error: failed to build gem native extension when installing rails on mac mountian lion os

によれば gcc-4.2 が /usr/bin にないからだ、とのこと。


# brew update
# brew install apple-gcc42
# sudo ln -s /usr/local/bin/gcc-4.2 /usr/bin/gcc-4.2


をおこなってから再度 bundle install でうまくいった。

Mavericks は無料になったけれど、OS のアップデートをすると、たいがい2、3日はそれまで動いていたものの修復に追われるので、人件費考えると依然高い。



プロフィール

株式会社まちクエスト代表、つくる社LLC代表。

Scratchで楽しく学ぶ アート&サイエンスRaspberry Piではじめる どきどきプログラミングを書きました。

Amazonから図書館検索 Libron、iPhoneアプリ ひらがなゲーム かなぶん を作っています。

Email: webmaster at champierre dot com

Twitter @jishiha

最近のエントリー

アーカイブ